Ma banque est à la page… d’erreur

On m’a toujours dit que les informaticiens étaient très bien payés dans les banques. Or, ma banque à moi, depuis que je la connais, a un site web qui permet de gérer son compte d’une manière particulièrement austère, très peu sécurisée, et par dessus le marché exploitant des technologies web dépassées.

Je passerai donc sous silence l’utilisation de frames pour vous faire découvrir ce magnifique écran d’accueil :

Avertissement d\'incompatibilité sur le site web de ma banque

Sur mon Mac, j’ai beau me connecter avec les dernières versions des navigateurs web compatibles avec mon système d’exploitation (Mac OS X 10.5 Leopard), en l’occurrence :

  • Opera 9.5,
  • Mozilla Firefox 3.0,
  • Safari 3.1.1,

j’obtiens invariablement la même page d’avertissement, en l’occurrence :

Attention è Votre version de navigateur est autorisée pour accéder à Cyberplus mais ne garantit pas un fonctionnement optimal.

Les navigateurs sont classés en trois catégories : homologués, autorisés ou non autorisés.

Les navigateurs homologués sont les suivants :

  • Windows : Internet Explorer 6.0 et 7.0, Firefox 1.5 et 2.0
  • Linux : Firefox 1.5 et 2.0
  • Mac OS X : Firefox 1.5 et 2.0, Safari 1.3, Safari 3.0.4 (Leopard Mac OS X 10.5)

Pour Widows 95, le navigateur Mozilla est autorisé.

Le service de compte en ligne Cyberplus n’a pas été testé avec votre version de navigateur.

Néanmoins, il n’a été reporté aucun problème de fonctionnement. En cas de problème rencontré, n’hésitez pas à nous contacter pour nous le signaler en nous fournissant le type et la version de votre navigateur.

Cliquez ici pour obtenir des informations sur la mise à jour de votre navigateur…

Continuer

Bon, alors j’hésite à leur indiquer que la redirection qui suit la pression du bouton Continuer (car bon, hein, pourquoi mettre un lien direct quand on peut rediriger l’utilisateur ?) n’est pas compatible avec Opera 9.5, pourtant l’un des navigateurs web les plus respectueux des standards et parmi les plus rapides du marché.

Ceci étant, je suis surtout très agacé de constaté que malgré toutes les annonces faites depuis des mois de la disponibilité de Firefox 3.0, le site ne soit toujours pas mis à jour en conséquence, et qu’il ne supporte pas non plus la dernière version en date du navigateur par défaut sous Mac, en l’occurrence Safari 3.1.1. Parce que ce qu’ils appellent une « mise à jour », moi, j’appelle ça une « rétrogradation »…

Autre point qui m’intrigue fortement : comment cela se fait-il que Windows 95 est autorisé à la connexion, alors que ce système d’exploitation n’est plus supporté par Microsoft depuis de nombreuses années, de sorte qu’il devient dangereux de l’utiliser sur Internet, et en particulier pour gérer ses comptes bancaires ?

Bref, en plus des groupes de télévision, on dirait que les banques ont elles aussi du mal à se mettre à Internet et à assurer un semblant d’interopérabilité

Speak Your Mind

*